From https://forum.mikrotik.com/viewtopic.php?t=87458#p439462 Thread, Configure multiple subnets with DHCP By h4ni8all Tue Jul 29, 2014 6:43 pm Hi, this should get you started: /interface bridge add disabled=no name=LAN-bridge add disabled=no name=LAN2-bridge add disabled=no name=LAN3-bridge create bridges for start. /interface ethernet set 0 disabled=no name=ether1-UPLINK set 1 disabled=no name=ether2-LAN set 2 disabled=no name=ether3-LAN set 3 disabled=no name=ether4-LAN2 set 4 disabled=no name=ether5-LAN2 set 5 disabled=no name=ether6-LAN3 set 6 disabled=no name=ether7-LAN3 prepare your interfaces. I just added two in each subnet. you can add more as you need. /ip pool add name=lan ranges=10.0.0.10-10.255.255.254 add name=lan2 ranges=192.168.0.10-192.168.0.254 add name=lan3 ranges=172.16.0.0-172.16.255.254 Create dhcp pools. /ip dhcp-server add address-pool=lan disabled=no interface=LAN-bridge lease-time=1w name=LAN add address-pool=lan2 disabled=no interface=LAN2-bridge lease-time=1w name=LAN2 add address-pool=lan3 disabled=no interface=LAN3-bridge lease-time=1w name=LAN3 create dhcp servers. /interface bridge port add bridge=LAN-bridge disabled=no interface=ether2-LAN add bridge=LAN-bridge disabled=no interface=ether3-LAN add bridge=LAN2-bridge disabled=no interface=ether4-LAN2 add bridge=LAN2-bridge disabled=no interface=ether5-LAN2 add bridge=LAN3-bridge disabled=no interface=ether6-LAN3 add bridge=LAN3-bridge disabled=no interface=ether7-LAN2 associate each port in its respective bridge. /ip address add address=10.0.0.1/8 disabled=no interface=LAN-bridge add address=192.168.0.1/24 disabled=no interface=LAN2-bridge add address=172.16.0.1/16 disabled=no interface=LAN3-bridge Set up the gateways for your subnets. /ip dhcp-server network add address=10.0.0.0/8 comment="lan" dns-server=8.8.8.8 gateway=10.0.0.1 netmask=8 add address=192.168.0.0/24 comment="lan2" dns-server=8.8.8.8 gateway=192.168.0.1 netmask=24 add address=172.16.0.0/16 comment="lan3" dns-server=8.8.8.8 gateway=172.16.0.1 netmask=16 create dhcp servers After this you're local side should be set. All you need now is NAT and set up your uplink towards ISP on ether1. Since I have no idea what kind of connection you have from them , its impossible to write anything. HTH. regards,